ユーザ用ツール

サイト用ツール


サイドバー

Tree

最近の更新

macyomoyama:phpmyadmin

phpMyAdmin on MacOSX

どうも、phpMyAdminの2.8以降は、設定が変わったみたいです。それ以前のを使った設定系の話は結構あるんだけど、ダウンロード先にOlderバージョンに該当の物がないのよね。今回は2.11を使用。

ダウンロード

 こちらから。

http://www.phpmyadmin.net/home_page/downloads.php

解凍し、作られたフォルダ を /Library/WebServer/Documents/に入れます。

設定

いきなり、アクセスします。

 http://127.0.0.1/phpMyAdmin/

すると、おこられます。そして、setup.phpをクリックせよと言ってくるはずです。クリックして設定に移ります。しかし、ここから試行錯誤して、設定までこぎ着けたので、あまりよくわかってない上に、説明できません。すいません。

確か、設定を行い、そして、設定ファイルを「download」します。そのファイル(config.inc.php)を、phpMyAdminに入れるだけです。それで、もういちど、アクセスします。

で、config.inc.phpですが、私のはこんな内容です。パスワードの部分はに置き換えてあります。

 <?php
 /*
  * Generated configuration file
  * Generated by: phpMyAdmin 2.11.4 setup script by Michal &#268;iha&#345; <michal@cihar.com>
  * Version: $Id: setup.php 10748 2007-10-10 07:30:59Z cybot_tm $
  * Date: Sun, 27 Jan 2008 13:57:53 GMT
  */
 /* Servers configuration */ 
 $i = 0;
 /* Server localhost (config:imayan) [1] */
 $i++;
 $cfg['Servers'][$i]['host'] = '127.0.0.1';
 $cfg['Servers'][$i]['extension'] = 'mysqli';
 $cfg['Servers'][$i]['connect_type'] = 'tcp';
 $cfg['Servers'][$i]['compress'] = false;
 $cfg['Servers'][$i]['controluser'] = 'root';
 $cfg['Servers'][$i]['controlpass'] = '****';
 $cfg['Servers'][$i]['auth_type'] = 'config';
 $cfg['Servers'][$i]['user'] = 'root';
 $cfg['Servers'][$i]['password'] = '****';
 /* End of servers configuration */
 ?>

うまくいかなかったら、confg.inc.phpを消して最初から。という風に何度もやりました。私の場合は、最終的にhost名を127.0.0.1とすることで、うまくいきました。ここをlocalhostとしていたのですが、それだとどうしてもうまくいかなかったです。

設定(windows2000編)

 会社のPCで訳あってphpMyAdminの2.11を入れてみましたが、setup.phpをクリック後、いくつか表示されるボタンで、Add Serverで設定します。結局設定は、MySQLのユーザ名とパスワードだけでいいです。その後、config.inc.phpをダウンロード(ボタンがあります)し、それをphpMyAdminのディレクトリにコピーするだけで起動するようになります。

localhostでダメだったら、127.0.0.1でやってみろってことですね。

起動

 起動は、

http://127.0.0.1/phpMyAdmin/

となりますが、たぶん、下の方に

お使いの PHP MySQL ライブラリのバージョン 5.0.45 が MySQL サーバのバージョン 4.1.22 と異なります。これは予期しない不具合を起こす可能性があります。

というメッセージが出ていると思います。一応動いてますが、ちゃんとしてサーバを動かすならあわせておく方がいいのでないのでしょうか。私の場合は、あくまでテスト用なので、どっちでもいいと思っています。

心配・・・

 しかし、このツールって。よくよく考えてみたら、かなり危険なものですよね。ここ破られたら、データベースのハックされちゃう。

 外のサーバで設置するときは、.htaccessの保護、パスワードの変更は必須ですね。あぶないあぶない。

macyomoyama/phpmyadmin.txt · 最終更新: 2013/07/21 18:01 by king